PS4 NAT Type Failed? Read here.


PS4 NAT Type Failed? Read here.

Hi there.


Lately lots of gamers attacking unifi and TM, saying that they blocked the access to their favourite online games.


It started with Rockstar, ubisoft and now NAT type for PS4.


It caused a lot of ruckus and fake news, however unifi and TM already made a statement that they are not blocking any game servers.


So, what's with NAT Type = Failed in PS4, mostly?


Well, it might be something to do with your servers itself. We recommend that you reach out to the server provider directly to check if your login ID has been compromised or if there are any configuration steps that you might need to check.


The error should look like this; (picture courtesy of @Irzadzul27 , add him on PSN)




So, what can you do if you are facing this problem?


For quick fix, you can follow this steps by one of our members here, @Frechette 


"I'd recommend trying to change you DNS to Google DNS ( 


You can do this by following these steps:


  1. Go to Settings.
  2. Go to Network.
  3. Go to Set Up Internet Connection.
  4. Select Wi-Fi/LAN depending on what you use to connect.
  5. Select Custom.
  6. IP Address Settings = Automatic.
  7. DHCP Host Name = Do Not Specify.
  8. DNS Settings = Manual. Primary DNS: Secondary DNS:

Let me know how you get on."


And yes, some said it works for them.


Why dont you try it first and share with us your result.









Re: PS4 NAT Type Failed? Read here.

Full statement by TM regarding this issue.




𝗪𝗲 𝗮𝗿𝗲 𝗴𝗮𝗺𝗲𝗿𝘀 𝘁𝗼𝗼

Hi everyone, recently we’ve received feedback that some unifi users, who are avid gamers, have had some problems accessing their favourite video game servers such as EA, Ubisoft and the PlayStation Network. Understandably, this has caused some frustration. We get it and we feel your frustration. After all, we’re gamers too.

And understandably, there has been some confusion on why these problems occurred. Difficulty accessing gaming servers is not a problem for unifi users only. We’ve checked. Gamers on other networks in Malaysia and around the world are going through the same thing.

There are a number of scenarios that may affect access to game servers. They include multiple logins and wrong login attempts. This has nothing to do with the unifi network itself. Please give us a moment to clarify some misconceptions.


𝗪𝗲 𝗱𝗼 𝗻𝗼𝘁 𝗯𝗹𝗼𝗰𝗸 𝗮𝗰𝗰𝗲𝘀𝘀 𝘁𝗼 𝗴𝗮𝗺𝗲 𝘀𝗲𝗿𝘃𝗲𝗿𝘀

A number of you have reached out to us via social media and our official customer service channels asking if we block access to game servers. We’d like to make it very clear that we don’t and have no reason to do so. Video games are a big part of a lot of people, including us.


𝗢𝘂𝗿 𝗻𝗲𝘁𝘄𝗼𝗿𝗸 𝗶𝘀 𝗯𝘂𝗶𝗹𝘁 𝗳𝗼𝗿 𝗴𝗮𝗺𝗲𝗿𝘀

With a fibre optic network that spans a distance farther than the moon, the unifi network is the most extensive fixed and mobile network in the country, and we’ve designed this network to cater for the demands of gamers just like you.

Our network comprises of 12 data centres, 20 submarine cables spanning the globe and over 560,000 kilometres of fibre optic cables to offer the best gaming experience for you.

Our state-of-the-art network operations centre proactively monitors our network and continuously optimizes data routes to mitigate and eliminate congestions to further improve your gaming experience.

At the same time, we’re always adding the latest game consoles in our labs as part of our test program to find out how we can further optimize our network for the newest consoles.

In addition, we have direct peering connections to some of the biggest game brands in the world.


𝗜𝗳 𝘆𝗼𝘂 𝗲𝗻𝗰𝗼𝘂𝗻𝘁𝗲𝗿 𝗽𝗿𝗼𝗯𝗹𝗲𝗺𝘀, 𝘄𝗵𝗮𝘁 𝗰𝗮𝗻 𝘆𝗼𝘂 𝗱𝗼?

First of all, it is very likely not a problem with the unifi network. The causes for problems accessing your favourite games server may vary and we recommend that you reach out to the server provider directly to check.


Head over to the unifi community. We have an active community of unifi users that help each other. The unifi community is the best place to find like-minded users that may have encountered a similar problem and have found a solution for it. Users having problems with their PSN Network Address Translation (NAT) configuration found that the solution offered here (…/unifi-…/NAT-TYPE/td-p/11810 ) help solved their issue.

We hope these tips will improve your gaming experience. If you have any questions, please feel free to reach out to us on social media, via live chat or phone. Thank you.

#wearegamerstoo #kamipungamers

Contributing Citizen ✪

Re: PS4 NAT Type Failed? Read here.

I still get NAT type 3 after doing that. How I can solve this??? 

Contributing Citizen ✪✪

Re: PS4 NAT Type Failed? Read here.

"Our network is built for gamers."


Yeah right, unifi speed and connection is pathethic. My speed always around 6 MBps and sometimes it even dropped to kpbs (kilobytes!!!) when playing online and the router is next to my PS4. My speed supposed to be over 100 MPBs of what I paid. Restart modem also no use. how is that even possible u tell me? 

Contributing Citizen ✪

Re: PS4 NAT Type Failed? Read here.

Just asking, how many devices connected to your network? Is there someone using Netflix or downloading at the same time? I suggested you change to aftermarket router.

Upholding Citizen ✪

Re: PS4 NAT Type Failed? Read here.

hahaha. dns server is the main issue. certain website cannot login also regarding about dns server

Contributing Citizen ✪✪

Re: PS4 NAT Type Failed? Read here.

How to fix the DNS Server? 

New-in-Town ✪✪

Re: PS4 NAT Type Failed? Read here.

Hello there,


I am facing the same issue suddenly for these few days.


I've already change the DNS and still have problem Failed NAT Type for my PS4.


Can you help to assist me? 



Contributing Citizen ✪

Re: PS4 NAT Type Failed? Read here.

Same me too, i used to dmz my ps4 and get nat type 2 but suddenly last night the nat type failed. Since then cant open apex legends or ea games

Contributing Citizen ✪

Re: PS4 NAT Type Failed? Read here.

Update, contacted live agent to restart connection but didnt work. Lastly requested new password and setup again the router. Nat type is 2 with lan connection now. It might fix it